MEDIUM6.0
PYSEC-2026-1774
pgAdmin failed to properly control the server code
Quick fix
PYSEC-2026-1774 — pgadmin4: upgrade to the fixed version with the command below.
pip install --upgrade 'pgadmin4>=7.7'Details
A flaw was found in pgAdmin. This issue occurs when the pgAdmin server HTTP API validates the path a user selects to external PostgreSQL utilities such as pg_dump and pg_restore. Versions of pgAdmin prior to 7.7 failed to properly control the server code executed on this API, allowing an authenticated user to run arbitrary commands on the server.
Are you affected?
Enter the version of the package you're using.
Affected packages
References
- https://nvd.nist.gov/vuln/detail/CVE-2023-5002[ADVISORY]
- https://github.com/pgadmin-org/pgadmin4/issues/6763[WEB]
- https://github.com/pgadmin-org/pgadmin4/commit/35f05e49b3632a0a674b9b36535a7fe2d93dd0c2[WEB]
- https://bugzilla.redhat.com/show_bug.cgi?id=2239164[WEB]
- https://github.com/pgadmin-org/pgadmin4[PACKAGE]
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/2S24D3S2GVNGTDNE6SF2OQSOPU3H72UW[WEB]
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/VIRTMQZEE6K7RD37ERZ2UFYFLEUXLQU3[WEB]
- https://pypi.org/project/pgadmin4[PACKAGE]
- https://github.com/advisories/GHSA-ghp8-52vx-77j4[ADVISORY]